2koolperformance 5pointcottage burgerworld northbayatvclub 2koolperformance 5pointcottage
Quaddealers
News and Announcements
Mudhole Links
Mudhole.ca is for sale!!
Contact Larry via email at admin@mudhole.ca for info!!
     

 

It is currently Sat May 26, 2018 4:05 am

All times are UTC-04:00




Post new topic  Reply to topic  [ 14 posts ] 
Author Message
Unread postPosted: Mon Apr 02, 2012 7:36 am 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
Engine light came on Saturday after going through a small but deep water hole in Cloyne. Light came on almost immediately. The water was not over the racks but about halfway up the engine. Stopped the machine, checked the oil, and made sure the rad was not plugged and nothing was interferring with the rad fan. Checked the fuzes and the 15Amp for the Rad Fan was blown. Replaced with the spare, fired her up and no engine light. We did check the fan at Whitefish Lake to see if it was not turning freely with the machine shut down. It appeared as though it was stiff to turn but could not be certain. Rode the 25km's back to the trucks and the fan did not come on at any time, even in the woods where I thought it would in the slow going in 4WD. Engine light did not come back on. The rad never overheated at any point and was not even overly hot to touch with the bare hand. Yesterday I had a better chance to check the fan at home and it is turning freely, no blockage or seizing. Wayne thinks it may have been the shock of the water hitting the fan when I went into the water that caused it to blow.

Anyway's, taking it to the dealer for a check today.......600km's...fuckin Kawi's

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Unread postPosted: Mon Apr 02, 2012 9:49 am 
Offline
User avatar

Joined: Tue Nov 15, 2011 12:26 pm
Posts: 16
My Ride: 2011 Polaris 850 2Up
Hey 17A

The experience I've had in the past with our fans is this. If they happen to be on when you enter the water or try to come on while your in the water, they have them set so sensitive now that they blow the fuse. The water is to heavy for the fan to push and it thinks it's blocked so instead of blowing the fan it flips the fuse.

Some guys we ride with that are hard core mudders have a fan shut off so they can manually turn the fan off and on when entering and playing in the deep water.

Just a thought

Dave


Top
   
Unread postPosted: Mon Apr 02, 2012 10:40 am 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
Thanx for that Dave....sure sounds like the probable symptoms. After I get her checked I'll post back here for all to know.

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Unread postPosted: Tue Apr 03, 2012 5:03 pm 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
Just had the machine checked at the place I bought it. Nothing wrong, it did what it was supposed to do, blow the fuze. As mentioned above probably the fan had been running when I went into the hole and either the water hitting the fan or a twig, mud etc jammed it for a moment and caused the fuze to blow. The cooling system was working normally at the shop and the fan came on when it was supposed to and shut off when it was supposed to.....

Fuckin Kawi's.... :grin:

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Unread postPosted: Tue Apr 03, 2012 6:29 pm 
Offline
User avatar

Joined: Tue Oct 14, 2008 7:02 am
Posts: 573
My Ride: 2008 Can-am 800xt
Location: Pickering, Ontario
great news.

At least you know to check the fuses the next time the engine light comes.
And keep some extra fuses on hand too.

keep the wheel side down

_________________
WayneR
Authorized Amsoil Dealer

SOLD:.....2008 Can-Am Outlander 800XT RED

2003 Kawasaki Vulcan 1500FI Nomad


Last edited by wildwr on Tue Apr 03, 2012 6:49 pm, edited 1 time in total.

Top
   
Unread postPosted: Tue Apr 03, 2012 6:40 pm 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
wildwr wrote:
great news.

At least you know to check the fuses the next time the engine light comes.
And some keep extra fuses on hand too.

keep the wheel side down


Hey Wayne...yup they gave me a few spares.

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Unread postPosted: Wed Apr 04, 2012 7:14 am 
Offline
User avatar

Joined: Wed Jul 25, 2007 10:17 am
Posts: 529
My Ride: O8 Can-am 800XT
Location: North Bay,ON
the biggings of a long list of frustrations you will have with the brute....keep us posted with them

_________________
Image
#98 TURNER PERFORMANCE/ LITMMPRO PRODUCTIONS
HIS-Can-Am 800XT CAMO
Full Ricochet skids, A-arm guards, 30" SilverBacks, RDC Swamplocks, Gorilla Rad Relocate, HMF exhaust, SRG snorkel, SRG Clutch Kit, BRP HPG shocks front rear, HD springs front & rear, Renegade Footpegs,2inch lift, Heated H&T warmer

HERS-09 Can-am 800R Renegade
28" SilverBacks, 312 rims, SRG snorkeled,Gorilla Rad relocate, Yellow HMF Utility Exhaust, Daulton Clutch kit, Full Skids


Top
   
Unread postPosted: Fri Apr 06, 2012 9:24 am 
Offline
User avatar

Joined: Fri Mar 09, 2007 11:45 am
Posts: 400
My Ride: 2016 Yamaha Grizzly
Location: Sudbury
Sounds like a fan switch mod is in order!! Or carry a case of fuses, as long as you don't have to change a fan.

_________________
2016 Yamaha Grizzly LE, Clic 54" Plow, dual TigerTails, Quadrax gas can holders, Kolpin rear box, Yamaha front box, RAM gas and GoPro mounts, Warn winch with synthetic line.

Gone 2004 Yamaha Grizzly 660, 26" MudLite XTR's, Montana Jack's Receivers, Champion winches and basket, Warn Contactor, TJD Cattracks, Kimpex Click"N"Go 48" Plow.


Top
   
Unread postPosted: Fri Apr 06, 2012 9:38 am 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
I'll let her be and see how things go over the summer. There is not a thing wrong. Could have happened to any machine if the fan got jammed for a moment. I love the machines power, handling, looks, suspension and ease of maintenance, but if it begins to do regular whig outs on me, she'll be outta here by fall.

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Unread postPosted: Fri Apr 06, 2012 10:02 am 
Offline
User avatar

Joined: Sun Nov 13, 2011 11:34 pm
Posts: 424
My Ride: 2013 Can-Am XMR 1000
Location: somewhere between Toronto and Haliburton
my old man has the same problem with his Cat TRV. he just usually rides with a pocket full of fuses lol. i've been told about a circut breaker that you can install that automaticly resets itself after the fact.

good luck bro

_________________
2013 Can-Am XMR 1000!!!

videos: http://www.youtube.com/user/McBongSmokey?feature=guide

KATVA Member


Top
   
Unread postPosted: Sat Apr 07, 2012 8:05 pm 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
Info.

110km's today in warmer conditions, tougher trails and deeper holes. The Brute ran flawlessly all day. Fan functioned as it should with no blown fuzes. conclusion....a momentary blockage of the fan blades last week hitting the water when the fan was on blew the fuze.

Fucking Outlander's were dropping like flies. One kept getting a plugged rad and overheating, the other had Power Steering failure.

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Unread postPosted: Sun Apr 08, 2012 11:09 am 
Offline
User avatar

Joined: Wed Jan 11, 2006 2:05 pm
Posts: 354
My Ride: 2012 BF750
Location: Atikokan, Ontario
That happened all the time on my 08...pain in the ass for sure. I rewired the fan circuit manually to a temp sensor/gauge unit with a switch and relay. When I raced, I would leave the fan on all the time.

I'll say this for any Kawi V-Twin...spend the money on the water pump impeller from TruroRecreationProducts. Don't buy a substitute...get the one from Ray (formerly FundyPowersports)

_________________
2004 V-Force
2012 Brute 750
2011 KFX90
2011 KLX110
1985 LT230
1986 LT160
gone but still loved...2006 Prairie 700, 2008 BF750i, 2009 Teryx 750
I don't list all the mods, but unless I supercharge the V Force, I've run out of things to do to it or bolt on to it.


Top
   
Unread postPosted: Sun Apr 15, 2012 9:14 pm 
Hey Dave
i think i am having a similar problem with my new-to-me 2010 brute...
had it out with my dad and stepdaughter a few weeks ago and the Temp light came on when i was crawling down a slow trail near our cottage... when i was running the rail beds (speeds of 30mph and 5 degree celsius weather) it stayed cool...

i think it is the water temperature sensor... so i am installing a fan override and a temp gauge on it so i dont have to rely on the idiot light on the dash...

funny thing is that Kawi didnt include this part on their parts drawing to the dealers... so when i called my local Kawi/Can-am dealer they didnt know at first what to order...


Top
   
Unread postPosted: Sun Apr 15, 2012 9:25 pm 
Offline
User avatar

Joined: Sat Jun 30, 2007 11:55 am
Posts: 3001
My Ride: 2014 Grizzly 700 SE
Location: Palmer Rapids, Ontario
BigEz wrote:
Hey Dave
i think i am having a similar problem with my new-to-me 2010 brute...
had it out with my dad and stepdaughter a few weeks ago and the Temp light came on when i was crawling down a slow trail near our cottage... when i was running the rail beds (speeds of 30mph and 5 degree celsius weather) it stayed cool...

i think it is the water temperature sensor... so i am installing a fan override and a temp gauge on it so i dont have to rely on the idiot light on the dash...

funny thing is that Kawi didnt include this part on their parts drawing to the dealers... so when i called my local Kawi/Can-am dealer they didnt know at first what to order...


That's nothing like mine. Mine was not overheating at all. Only a blown fuze.

_________________
Dave
2014 Grizzly 700 SE - Tactical Black


- Zillas wrapped around SS 212 Black Matte Rims
- Yamaha Skids
- 3000 lb Superwinch
- Grip and Thumb Warmers
- Moose Rear Soft Bag
- Garmin GPS Map62s / RAM Mount
- SPOT 2 Satelite Messenger
- GoPro HD Helmut Cam



Photos: http://s203.photobucket.com/albums/aa17 ... adventure/
Video:(2007 - Present) - YouTube: http://www.youtube.com/user/My17A/videos?view=pl


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 14 posts ] 

All times are UTC-04:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited
American English Language Pack © MaĆ«l Soucaze